推荐一款“骑马订”打印的好软件

【明慧网】推荐一款“骑马订”打印的好软件

一、简介

“折页打印辅助程序 FOR WORD2000（也支持XP）”是一款专门用来打印“骑马订”小册子的辅助软件 （注：如果读者需要源程序代码的话，打开工程的密码是：“MhBh 1992”，注意大小写及中间的空格。），它有下述功能：

1、支持两版合一、四版合一、八版合一、……最高支持64版合一（按“骑马订”格式在一张纸上打印64个小页面），因此可以打出超小版本的书籍来；

2、在折页打印时，如果原稿的总页数不符合打印的需要，程序会自动增加所需页面。比如在八版合一、原稿是35页的情况下，程序将自动增加13页空白页，无需手工操作；

3、增加的页面可以不做为小册子的一部份，也就是说在（裁剪后）装订时，增加的页面可以去掉不用装订到小册子中。比如上面的例子，在普通方式下打印时，增加的13页空白页将做为小册子的一部份，也就是说小册子的最后13张全部是空白张；当采用上述方式进行打印时，增加的空白页面只有一张是附加在小册的最后（小册子只有最后一张是空白张。因为打印出的小册子总页数肯定是四的整数倍，所以在补足四的整数倍之后的页面才会被裁除，另外对此功能进行测试时，必须得使增加的页数大于四页，并且最少得用四版合一功能进行打印）；

4、反面打印时可以按“逆页序”进行打印。不同的打印机打印输出时的页面叠放顺序也可能不一样，甚至同一部打印机用不同的出纸道输出时的页面叠放顺序也可能不一样，在必要时就需要进行“逆页序”打印；

5、可以打印指定页。在打印几十页的文稿时时我们经常遇到某一张或几张稿子打印坏的情况，如卡纸、打印稿倾斜，这时就需要补打某一页或几页，在本程序中只需输入需要重新打印的是第几页（或输入“拼版后的总第几页”），程序就能自动地把该指定页打印出来。比如上面的例子，如果原稿中第八页所在的页面需要重新打印（在八合一的情况下，它对应于打印出的稿件中的总第四页），只需要在输入8（或在“拼版后总第几页”输入框中输入4）就能把该页重新打印了；

6、可以生成打印页码序列（有关WORD2000下进行拼页打印时打印页码的格式，明慧网上已经有几篇文章都详细地介绍过了，请参看有关文章），以供特殊需要。

7、对一篇文章排好版之后，比如当把《精进要旨（二）》排好版后，不用改动排好版的稿子，就能直接打印出二合一、四合一、甚至更小的袖珍版的《精进要旨（二）》来。也就是说可以只排一次版，就能打印出不同规格（大小）的小册子来。

举个例子来讲：明慧网前段时间提供的《明慧周刊》是A4幅面，并不方便打印，在进行重新排时，如果把纸张大小设为A5，原稿就会变得很乱，增加了二次排版的难度；我通常的做法是把字体放大（如正文字体放大为三号字等），这样排起版来就很快很容易，排好版后直接用此辅助程序进行“二合一”打印，就得到了合适的打印稿。

8、不管原稿是什么幅面，可以是A4、A5、32开等，他都会按照你在程序中选择的打印纸大小和每页打印版面数目来打印。比如原稿是32开的，你照样可以在程序中选A4纸，打印2版或4版。原稿是A4的，你也可以在程序中选8开纸，打印2版或4版。

程序界面如图：

二、程序的安装

WORD2000在缺省安装情况下（没改变程序安装时的目录），只需要把这个QMDPrint.dot直接拷贝到下述目录下就行了：C:\Program Files\Microsoft Office\Office\Startup。如果你把WORD2000安装到其它目录中去了，请把这个DOT文件拷贝到相应的路径下的“\Office\Startup”中去就行了。请点击这里下载 QMDPrint.zip 文档

拷贝后就完成了安装，下次在运行WORD2000时，该辅助程序就会被自动调入。这种安装方法避免了修改你原有的公用模板文件。WORD2000的程序界面也不会发生变化，只是多增加了一个如图二所示的工具条。

三、使用说明

程序中已经包含了比较详尽的说明，下面就使用技巧和注意事项做个说明。

1、注意事项

①、在程序界面的中间上部，可以看到当前文件名。如果你同时打开了多个WORD2000文件，在调用本辅助程序时，有可能打印的文件不是你想打印的文件。例如：如果同时用WORD2000编辑A.doc、B.doc两个文件，在A.doc中调用本辅助程序并退出后，WORD2000可能回到文件B.doc上（即B.doc可能会变成当前文件），这时再调用本辅助程序时，打印的就是B.doc了。要想知道正要打印的文件是哪一个，看一下“当前文件名”就行了。

②、改变WORD2000的当前打印机。 同时按下 Ctrl 和 P 键，或者在“文件”菜单下选择“打印”功能，在“打印”对话框中选择好打印机，然后按“关闭”键即可（一定不要按“确定”，不然就是执行WORD2000的打印功能了）。

要生成PDF文件，也在“打印”对话框中选择Acrobat PDFWriter(生成的文件需字体支持，比较小)，或Acrobat Distiller(生成的文件自带字体支持，稍大)，然后按“关闭”键，再调用本辅助程序打印即可。(Acrobat软件，安装时选自定义安装，将Acrobat PDFWriter选上)

③、因为打印出的小册子总页数肯定是四的整数倍，所以在排版时，尽可能地把稿件的总页数排成四的整数倍。这样就不浪费。

④、因为WORD2000中进行拼页打印时，是按照页码进行打印，由于WORD2000本身的问题，当一篇WORD文件中如果有两个页码序列时（最简单的判断就是：如果文件最后一页的页码和文件的总页数不同，这篇WORD文件中就有至少两个页码序列），这种拼页打印就不能正确完成打印任务。

所以如果你需要进行骑马订打印的话，就要保证两点：一是同一篇WORD文件中不能用两个页码序列；二是文件的起始页码必须为1（但是在文稿中可以不插入任何页码），但首页可以不显示页码。

要改变页码编排，可在“文件”菜单下选择“插入”功能，在“页码”对话框中选择“格式”，在“页码编排”中选“续前节”。

2、技巧

①、程序自动增加的空白页往往都有页码，为了使打印出来的稿子好看些，可以先调用本辅助程序，看一看要增加多少空白页，退出程序后，自己手工增加所需的空白页。然后用WORD的“插入”菜单下的“插入文本框”功能插入一个文本框，双击这个文本框的边框，在弹出的对话框中把线条的颜色设为“无线条颜色”，然后把这个“看不到”的文本框拖到页码的上面，把页码盖住就行了。

你可能在手工增加页面后，还想使用本辅助程序的“把增加页作为小册子一部份”的功能，这是一个非常实用的功能。你要想达到这样一个目的只需要在本辅助程序左下方的“在文件的最后手工增加的空白页数”一栏中输入自己手工增加的实际页数就行了，方便的是：如果这篇文稿需要增加13页空白页，而自己手工只增加了1页空白页的话（在一开始所举的那个实际例子中，只要手工增加一页盖住页码的空白页，打出来的稿子最后一页就不带页码了），只需要在这一栏中输入“1”就行了。

②、充份利用“打印自定义页码”功能。

选择本辅助程序中间下方的“只生成打印页序列”功能，然后根据需要按“打印全部页面”或“打印正面”或“打印反面”键，这时在中间的大文本框中就生成了“打印页码序列”，把这些页码序列复制下来，然后按程序最下方的说明“粘贴”到“自定义页码输入框”中，对这些页码序列按照需要进行适当编辑后，按“打印自定义页码”键进行打印。

例如，我在打印师父新经文《大法好》时，就先在A5版面上进行排版，只需要排成一页，然后调用本辅助程序进行打印。在“自定义页码输入框”中按页码序列的格式输入“1,1,1,1”（注意页码序列的最后一定不能带上逗号，并且所有的逗号与数字必须为英文数字！），然后按“打印自定义页码”就在一张A4纸上打印出两版合一的文稿了（节省了编辑文稿的一些操作）。

再例如，本辅助程序只提供了打印指定页的功能，如果在打印时的要求是不打印某一指定页，就可以用前面所述的办法，对这些页码序列按照需要进行这样的编辑：把指定页所对应的页码序列从这些数据中去掉，然后按“打印自定义页码”就行了（指定页所对应的页码序列可以“打印指定页”中输入一下就得到了）。

③、由于受WORD本身的限制，打印出来的文稿可能不在打印纸的正中间（左右页边距不一样），这样打印出来的文稿就不能很好装订，解决办法是先生成PDF文件，然后再打印。

注意生成PDF文件时，不能用“Adobe PDFMaker”打印虚拟驱动程序，而要用“Acrobat Distiller”，并注意该打印虚拟程序的选项：“改变EPS文件的页面尺寸并使作品居中”要选择上（该选项在“Acrobat Distiller 属性”─>“Acrobat Distiller 打印首选项”─>“编辑转换设置”─>“高级”菜单下）。用这样的办法就能生成完全居中的可打印文稿了。 若打印出来的文稿还不满意，可用ACROBAT中的“TOUCHUP 对象工具”来改变页面的位置，使打印出来的东西符合自己的要求。

有时打印出来的小册子，可能会装订的位置太窄，而页边距又太大，这时可以在页面设置中选“对称页边距”，并将“内侧”页边距设置比“外侧”页边距大一些，这样就可达到要求。比如打印4版小册子时，可将“内侧”页边距设置为16mm, “外侧”页边距为10mm。

四、其它辅助功能

为了编辑排版的方便，我在这个辅助程序中加入了几个常用的功能（见图二）。

1、电子书的排版程序。用过“德赛数码龙”或“金博览掌上读”的功友都知道这两款电子书都不能正确地显示出文章的段落格式，看上去比较混乱，我就做了这个小程序来解决这一问题。通过这个小程序排版出来的文件，专门用于上述两款电子书，收到了极佳的显示效果。

2、排版文件时，有时为了控制排版的总页数，我们经常把段落中的“行距”设为“固定值”，在对排版的总页数进行调整时，常常要改变“行距”，这里就做了四个小程序，用于增加、减小行间距。这四个小程序能正确运行的条件是：所选择的段落必须已经把“行距”设为“固定值”，并且所选择的部份的行距必须相同，不能这一段的行距是13，另一段的行距是14，把这两段选择起来后用这四个小程序进行统一改变行距就会出错。

3、把明慧网上的文章复制、粘贴到WORD2000中后，常常会有很多无用的空行（多余回车符），“多余回车符处理”就是用来删除这些多余的空行的。

4、明慧网上的文章一般都有一个固定的格式：第一行是标题，第二是作者名及日期，第三行都是以“【明慧网】”字样开头。根据这个固定的格式，我在自己编辑打印明 慧文章时，就做了这个“自动标题”排版。原理是：从光标当前所在位置处开始查找下一个“【”，找到后（这一般就是明慧网文章的第三行）就把文章的标题进行自动排版（执行一次只排一个标题，这样方便校对、调整）。大大提高了排版的效率、同时也减少了漏排的几率，很实用。


word文档制作成PDF文档的方法

2002年11月8日 文/大陆弟子

（一）概述：普通word文档在资料传递过程中非常容易在无意中被改动和损坏，而PDF文档一般是难于改动的，因此更适合于传递。有些PDF文档制作工具也可以制作出PDF文档，但操作起来不是很方便，对中文支持的也不是很好，这里介绍以Microsoft Word为制作主体，用Acrobat来生成PDF文档的制作方法。

（二）需要软件
Microsoft Word、Acrobat 5.0（注意不是Acrobat Reader)

（三）程序的安装

1、Word已安装好

2、Acrobat的安装

需要注意的是Acrobat必需选择自定义安装，将Acrobat PDFWriter,亚洲语言支持,选上。

3、安装好之后，打开Word,在打印机选择栏中应该有Acrobat Distiller,和Acrobat PDFWriter 虚拟打印机。如下图。

（四）使用

1、文件在word中编辑好后。在word中选择打印，选择打印机Acrobat Distiller 和Acrobat PDFWriter, 这两个随便选一个打印，像普通打印机一样使用，只不过打印出来的pdf文件而不是纸。这样你的pdf文件便做成了。PDFWriter需字体支持，所以文件体积小，Distiller本身包含字体，所以文件大。我们一般用到的都是Distiller打的。如果往国内发信和在支持中文地区使用，建议打成PDFWriter,这样文件小，便于发行(那两个打印机是Acrobat自带的虚拟打印机，PDFWriter是Acrobat自带的打印机（虚拟），打印到硬盘保存。)只有自定义安张才有PDFWriter.
2、如果你想打印将4合1的pdf文件，你必须用到骑马订打印程序。用骑马订打印程序,先在打印中将打印机设置为PDFWriter或Distriller，单击取消，然后启动骑马订打印程序，打印。

（五）Acrobat的一点使用经验（前提pdf文件没有被加密）

1、改pdf的错字及增加或删除内容

选了"TouchUp文本工具"后单击PDF文件的任何地方，你可以对其中的文本文字进行修改，可以删除，复制，粘贴。
"TouchUp对象工具"是指选中一行(或者一个页面／段）之后你能对该行（整个页面／段）作为整体进行删除，复制，粘贴等操作。 可以对整个页面进行调整，以适应打印页面，使其打印出来后适合装订和阅读。
工具拦中还有另一T型按钮，那是全局选择按钮，你可以用来选择全部文字和整个版面进行操作。

2、单击菜单栏的文档，里面有一些工具很实用。

3、打印横排版的文件时，应将“自动旋转并居中页面”选上

4、几天前发表的小册子《与你同行》从内容到编排都很好，可惜有些图片打印出来太淡，很难用来复印。下面谈一谈如何处理和优化PDF文件中的图片：

首先应安装ACROBAT软件（不是Acrobat Reader）和Photoshop软件，先打开Photoshop，然后用Acrobat打开PDF文件，在Acrobat菜单中选TOUCHUP对象工具，选中要修改的图片，点击右键，选“编辑图像”，然后选中的图像就自动在Photoshop中打开了，在Photoshop菜单“图像”栏中，选“调整，亮度／对比度…”，调整图像的亮度和对比度，直到满意为止。关闭图像，软件自动会问“要在关闭之前存储对…的更改吗？”，选“是”，PDF文件中的图片就已经修改好了。另外不要忘记存储修改过的PDF文件。可将修改好的文件先关闭，再打开打印，否则有时会出现乱码。

另外有些PDF文件打印出来后不是太对称，也可用“TOUCHUP对象工具”，选取要移动的对象，作上下左右移动，直到适合你打印机。有些文件打印出来后太靠边，应在打印时选“缩小超大页面适合纸张大小”。